Facing issue with php 5.5.x in Ubuntu 14.04.5 LTS

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

Facing issue with php 5.5.x in Ubuntu 14.04.5 LTS

Amey Abhyankar

I am getting php related errors in my product running on 14.04.5 LTS.
Details as follows =

Error =

[Mon Mar 301708 2018] [:error] [pid 19149] [client <ip_address>:45627]
PHP Fatal error:  Call to a member function getLanguage() on a
non-object in /opt/user/<code_path>/webroot/inc/include.php on line

line 198 = define("sLANG", $_SESSION['obj_ClientConfig']->getLanguage() );

php version = PHP 5.5.9-1ubuntu4.23 (cli) (built: Feb  8 2018 21:59:47)
OS = Ubuntu 14.04.5 LTS [64bit]
uname = 3.13.0-133-generic #182-Ubuntu SMP Tue Sep 19 15:49:21 UTC
2017 x86_64 x86_64 x86_64 GNU/Linux

Additional info: Same code works fine with php 5.4 & on Debian 7.
I checked changelog of php 5.5 but not getting any useful pointers.

What can be the issue?

Thanks & Regards,

ubuntu-users mailing list
[hidden email]
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users