Package dependency paradox with package 'tuned'

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Package dependency paradox with package 'tuned'

Eino Virtanen
I am using CentOS with a PREEMPT Kernel. I ran an update and
encountered the following error:

###
--> Running transaction check
---> Package device-mapper-multipath-libs.x86_64 0:0.4.9-119.el7 will
be installed
--> Processing Dependency: librados.so.2()(64bit) for package:
device-mapper-multipath-libs-0.4.9-119.el7.x86_64
---> Package tuned.noarch 0:2.8.0-5.el7_4.2 will be updated
--> Processing Dependency: tuned = 2.8.0 for package:
tuned-profiles-realtime-2.8.0-5.el7.noarch
--> Running transaction check
---> Package librados2.x86_64 1:0.94.5-2.el7 will be installed
---> Package tuned.noarch 0:2.8.0-5.el7_4.2 will be updated
--> Processing Dependency: tuned = 2.8.0 for package:
tuned-profiles-realtime-2.8.0-5.el7.noarch
--> Finished Dependency Resolution
Error: Package: tuned-profiles-realtime-2.8.0-5.el7.noarch (@rt)
           Requires: tuned = 2.8.0
           Removing: tuned-2.8.0-5.el7_4.2.noarch (@updates)
               tuned = 2.8.0-5.el7_4.2
           Updated By: tuned-2.9.0-1.el7.noarch (base)
               tuned = 2.9.0-1.el7
           Available: tuned-2.7.1-5.el7.noarch (rt)
               tuned = 2.7.1-5.el7
           Available: tuned-2.8.0-5.el7.noarch (rt)
               tuned = 2.8.0-5.el7
###

My interpretation is that the 'tuned-profiles-realtime' requires
'tuned' version '2.8.0', but version '2.9.0-1.el7' is currently
installed? Should I force installation of 'tuned' version '2.8.0', or
what would be a sensible solution to this problem?


Thank you in advance,

-E
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Package dependency paradox with package 'tuned'

stan-3
On Mon, 14 May 2018 13:05:41 +0200
Eino Virtanen <[hidden email]> wrote:

> Error: Package: tuned-profiles-realtime-2.8.0-5.el7.noarch (@rt)
>            Requires: tuned = 2.8.0
>            Removing: tuned-2.8.0-5.el7_4.2.noarch (@updates)
>                tuned = 2.8.0-5.el7_4.2
>            Updated By: tuned-2.9.0-1.el7.noarch (base)
>                tuned = 2.9.0-1.el7
>            Available: tuned-2.7.1-5.el7.noarch (rt)
>                tuned = 2.7.1-5.el7
>            Available: tuned-2.8.0-5.el7.noarch (rt)
>                tuned = 2.8.0-5.el7
> ###
>
> My interpretation is that the 'tuned-profiles-realtime' requires
> 'tuned' version '2.8.0', but version '2.9.0-1.el7' is currently
> installed? Should I force installation of 'tuned' version '2.8.0', or
> what would be a sensible solution to this problem?

My interpretation is that 'tuned-profiles-realtime' needs to be
compiled with tuned version '2.9.0-1.el7.  Because it requires
version 2.8 of tuned, it is blocking the update to tuned 2.9.

You should open a bugzilla against tuned-profiles-realtime asking for
it to be recompiled with tuned 2.9.  Maybe it's already done, and just
waiting in testing for enough karma, and you've just been caught by a
timing issue, though.  So, you could wait a day or two to see if the
situation resolves itself.

PS this is the Fedora list, your question is probably more appropriate
for a centos list, if there is one.  I know, I know, cousins.
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Package dependency paradox with package 'tuned'

Eino Virtanen
Ah, allright, thanks for clearing that up for me Stan!

--
Sent from mobile. Please excuse any typos.

On Mon, May 14, 2018, 17:44 stan <[hidden email]> wrote:
On Mon, 14 May 2018 13:05:41 +0200
Eino Virtanen <[hidden email]> wrote:

> Error: Package: tuned-profiles-realtime-2.8.0-5.el7.noarch (@rt)
>            Requires: tuned = 2.8.0
>            Removing: tuned-2.8.0-5.el7_4.2.noarch (@updates)
>                tuned = 2.8.0-5.el7_4.2
>            Updated By: tuned-2.9.0-1.el7.noarch (base)
>                tuned = 2.9.0-1.el7
>            Available: tuned-2.7.1-5.el7.noarch (rt)
>                tuned = 2.7.1-5.el7
>            Available: tuned-2.8.0-5.el7.noarch (rt)
>                tuned = 2.8.0-5.el7
> ###
>
> My interpretation is that the 'tuned-profiles-realtime' requires
> 'tuned' version '2.8.0', but version '2.9.0-1.el7' is currently
> installed? Should I force installation of 'tuned' version '2.8.0', or
> what would be a sensible solution to this problem?

My interpretation is that 'tuned-profiles-realtime' needs to be
compiled with tuned version '2.9.0-1.el7.  Because it requires
version 2.8 of tuned, it is blocking the update to tuned 2.9.

You should open a bugzilla against tuned-profiles-realtime asking for
it to be recompiled with tuned 2.9.  Maybe it's already done, and just
waiting in testing for enough karma, and you've just been caught by a
timing issue, though.  So, you could wait a day or two to see if the
situation resolves itself.

PS this is the Fedora list, your question is probably more appropriate
for a centos list, if there is one.  I know, I know, cousins.
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]

_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: Package dependency paradox with package 'tuned'

stan-3
On Tue, 15 May 2018 08:34:07 +0200
Eino Virtanen <[hidden email]> wrote:

> Ah, allright, thanks for clearing that up for me Stan!

You're welcome, glad it helped.
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]