Re: [CentOS] Issue with Perl and rpmforge - advice? - SOLVED

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: [CentOS] Issue with Perl and rpmforge - advice? - SOLVED

Harshvardhan koshti
I have Net::SSLeay installed however still get the same error

Error: Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by package
perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
Net::SSLeay is up to date (1.36)

Any suggestions?




_______________________________________________
CentOS mailing list
[hidden email]
http://lists.centos.org/mailman/listinfo/centos
Reply | Threaded
Open this post in threaded view
|

Re: [CentOS] Issue with Perl and rpmforge - advice? - SOLVED

Les Mikesell
On 6/13/2011 1:07 PM, Harshvardhan koshti wrote:
> I have Net::SSLeay installed however still get the same error
>
> Error: Missing Dependency: perl(Net::SSLeay)>= 1.33 is needed by package
> perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
> Net::SSLeay is up to date (1.36)
>
> Any suggestions?

Don't mix 3rd party repositories?

Have done an 'update rpmforge-release' since it was rearranged into 3
different repos and if so are you doing something to enable the parts
that overwrite core packages?  Or if your Net::SSLeay came from
somewhere else it might not be marked as supplying the dependency you need.

--
   Les Mikesell
    [hidden email]
_______________________________________________
CentOS mailing list
[hidden email]
http://lists.centos.org/mailman/listinfo/centos
Reply | Threaded
Open this post in threaded view
|

Re: [CentOS] Issue with Perl and rpmforge - advice? - SOLVED

Craig White
In reply to this post by Harshvardhan koshti

On Jun 13, 2011, at 11:07 AM, Harshvardhan koshti wrote:

> I have Net::SSLeay installed however still get the same error
>
> Error: Missing Dependency: perl(Net::SSLeay) >= 1.33 is needed by package
> perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
> Net::SSLeay is up to date (1.36)
----
sounds as if you are using an older version of memcache because I ran into that same issue here

where did you get Net::SSLeay from?

You can download them from rpmforge...

wget http://packages.sw.be/perl-Net-SSLeay/perl-Net-SSLeay-1.36-1.el5.rfx.i386.rpm
wget http://packages.sw.be/perl-Net-SSLeay/perl-Net-SSLeay-1.36-1.el5.rfx.x86_64.rpm

Craig
_______________________________________________
CentOS mailing list
[hidden email]
http://lists.centos.org/mailman/listinfo/centos
Reply | Threaded
Open this post in threaded view
|

Re: [CentOS] Issue with Perl and rpmforge - advice? - SOLVED

Les Mikesell
On 6/13/2011 4:32 PM, Craig White wrote:

>
> On Jun 13, 2011, at 11:07 AM, Harshvardhan koshti wrote:
>
>> I have Net::SSLeay installed however still get the same error
>>
>> Error: Missing Dependency: perl(Net::SSLeay)>= 1.33 is needed by package
>> perl-AnyEvent-5.240-1.el5.rf.noarch (rpmforge)
>> Net::SSLeay is up to date (1.36)
> ----
> sounds as if you are using an older version of memcache because I ran into that same issue here

For memcache you can just 'yum remove' the rpmforge version and install
again from EPEL which won't need all the weird dependencies.  There
might be a difference in the user it runs as but otherwise they are
compatible.

--
   Les Mikesell
    [hidden email]


_______________________________________________
CentOS mailing list
[hidden email]
http://lists.centos.org/mailman/listinfo/centos