label disappearing at reboot

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

label disappearing at reboot

Luca Ferrari-2
Hi all,
on a testing virtual machine I have a virtual disk labeled via glabel
disappearing at each reboot (11-RELEASE).

When the system boots it is turned into single user mode because it
cannot mount DATA4 as it has disappeared.
In particular on the console it is printed:

mount: /dev/label/DATA4: No such file or directory

And effectively the lanel has disappeared. I try to recreate the whole
partition and label from scratch as follows, and effectively I'm able
to mount the filesystem after that, but every time the machine is
rebooted the disk label disappear. What am I missing?

root@olivia:~ # glabel list ada4
Geom name: ada4
1. Name: diskid/DISK-VB97f8d8f5-8f70a2a4
   Mediasize: 2147483648 (2.0G)
   Sectorsize: 512
   Mode: r0w0e0
   secoffset: 0
   offset: 0
   seclength: 4194304
   length: 2147483648
   index: 0
1. Name: ada4
   Mediasize: 2147483648 (2.0G)
   Sectorsize: 512
   Mode: r0w0e0

root@olivia:~ # gpart create -s GPT ada4
ada4 created
root@olivia:~ # gpart add -t freebsd-ufs ada4
ada4p1 added

root@olivia:~ # glabel create DATA4 ada4p1
root@olivia:~ # newfs  label/DATA4
label/DATA4: 2048.0MB (4194224 sectors) block size 32768, fragment size 4096
        using 4 cylinder groups of 512.00MB, 16384 blks, 65536 inodes.
super-block backups (for fsck_ffs -b #) at:
 192, 1048768, 2097344, 3145920
root@olivia:~ # echo "/dev/label/DATA4 /mnt/data4 ufs rw 0 0" >> /etc/fstab
root@olivia:~ # mount -a
[hidden email] mailing list
To unsubscribe, send any mail to "[hidden email]"