libesmtp-devel

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

libesmtp-devel

Paolo Galtieri
Folks,
   I run the bro network security monitor.  Due to recent changes in
openssl the bro monitor will no longer compile with openssl 1.1 only
with openssl 1.0.  As a result I had to uninstall openssl-devel and
install the compat-openssl10-devel package.  As part of the removal of
openssl-devel the libesmtp-devel and net-snmp-devel packages were also
removed.  I have other software that uses libesmtp-devel.  I can't
install libesmtp-devel due to conflicts with openssl.  Is there anyway
to re-install the libesmtp-devel and net-snmp-devel packages?

Any help is appreciated.

Paolo
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Fedora Code of Conduct: https://getfedora.org/code-of-conduct.html
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/users@.../message/C6IEP6CWMSIDQXAXWQBXBCS2WP3LEIZV/
Reply | Threaded
Open this post in threaded view
|

Re: libesmtp-devel

Todd Zullinger
Hi,

Paolo Galtieri wrote:
> I run the bro network security monitor.  Due to recent changes in openssl
> the bro monitor will no longer compile with openssl 1.1 only with openssl
> 1.0.  As a result I had to uninstall openssl-devel and install the
> compat-openssl10-devel package.  As part of the removal of openssl-devel the
> libesmtp-devel and net-snmp-devel packages were also removed.  I have other
> software that uses libesmtp-devel.  I can't install libesmtp-devel due to
> conflicts with openssl.  Is there anyway to re-install the libesmtp-devel
> and net-snmp-devel packages?

I don't think so, as the conflict with openssl-devel and
compat-openssl10-devel isn't something you can (reasonably)
work around.

Why do you need the -devel packages installed on the same
system?  Unless the bro software somehow needs the openssl
1.0 headers at run time, you should be able to build it,
then remove compat-openssl10-devel and reinstall the
openssl-devel package.

(If it is a runtime dependency, then I don't think there's
any good options, but that seems unlikely.)

An somewhat better solution is to build in mock or some
other container.  Then you don't need to have any -devel
packages installed.

And, of course, the best solution would be for bro to
support openssl-1.1.  I would think security software would
be keeping up with openssl. ;)

--
Todd
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
For a list of all the ways technology has failed to improve the
quality of life, please press three.
    -- Alice Kahn, writer


_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Fedora Code of Conduct: https://getfedora.org/code-of-conduct.html
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/users@.../message/GEEHINCRRF4SQXTEXJ3JTI2J4FJ52ALQ/

signature.asc (555 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: libesmtp-devel

Paolo Galtieri
I know I could uninstall the compat devel package and re-install the openssl devel package, but then if there are updates to bro I would have to uninstall the openssl-devel package and re-install the compat devel package.  I was hoping there would be some way to avoid this.

Paolo
 
On 06/09/2018 03:19 PM, Todd Zullinger wrote:
Hi,

Paolo Galtieri wrote:
I run the bro network security monitor.  Due to recent changes in openssl
the bro monitor will no longer compile with openssl 1.1 only with openssl
1.0.  As a result I had to uninstall openssl-devel and install the
compat-openssl10-devel package.  As part of the removal of openssl-devel the
libesmtp-devel and net-snmp-devel packages were also removed.  I have other
software that uses libesmtp-devel.  I can't install libesmtp-devel due to
conflicts with openssl.  Is there anyway to re-install the libesmtp-devel
and net-snmp-devel packages?
I don't think so, as the conflict with openssl-devel and
compat-openssl10-devel isn't something you can (reasonably)
work around.

Why do you need the -devel packages installed on the same
system?  Unless the bro software somehow needs the openssl
1.0 headers at run time, you should be able to build it,
then remove compat-openssl10-devel and reinstall the
openssl-devel package.

(If it is a runtime dependency, then I don't think there's
any good options, but that seems unlikely.)

An somewhat better solution is to build in mock or some
other container.  Then you don't need to have any -devel
packages installed.

And, of course, the best solution would be for bro to
support openssl-1.1.  I would think security software would
be keeping up with openssl. ;)



_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Fedora Code of Conduct: https://getfedora.org/code-of-conduct.html
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/users@.../message/GEEHINCRRF4SQXTEXJ3JTI2J4FJ52ALQ/


_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Fedora Code of Conduct: https://getfedora.org/code-of-conduct.html
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/users@.../message/7DPRJ6EM2F4MJEQSNTLR3RWIHMR2AFCA/
Reply | Threaded
Open this post in threaded view
|

Re: libesmtp-devel

Todd Zullinger
Paolo Galtieri wrote:
> I know I could uninstall the compat devel package and re-install the openssl
> devel package, but then if there are updates to bro I would have to
> uninstall the openssl-devel package and re-install the compat devel
> package.  I was hoping there would be some way to avoid this.

Nothing comes to mind.  If you build this often, making a
container which provides a build environment is probably the
easiest route.

--
Todd
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
If age imparted wisdom, there wouldn't be any old fools.
    -- Claudia Young


_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Fedora Code of Conduct: https://getfedora.org/code-of-conduct.html
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/users@.../message/BG7P7NN5GQC5LXYE3K26KNHXZGF2ZL7U/

signature.asc (555 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: libesmtp-devel

Gordon Messmer-2
In reply to this post by Paolo Galtieri
On 06/09/2018 12:37 PM, Paolo Galtieri wrote:
> Is there anyway to re-install the libesmtp-devel and net-snmp-devel
> packages?


yum install mock
cp /etc/mock/epel-7-x86_64.cfg /etc/mock/build-bro.cfg
# Fix the first line (the "root") in /etc/mock/build-bro.cfg
mock -r build-bro --install compat-openssl10-devel

Use "mock -r build-bro --shell" (and then "su - mockbuild" in the mock
shell) to build the bro monitor.

Use "mock -r epel-7-x86_64 --shell" to build everything else.

Periodically, mock will decide that the root is too old and will throw
it away.  You can manually install it as above, or you can add it to the
chroot_setup_cmd line:

config_opts['chroot_setup_cmd'] = 'install @buildsys-build
compat-openssl10-devel'
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Fedora Code of Conduct: https://getfedora.org/code-of-conduct.html
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/users@.../message/XKCBVQ5AYZMY5VFGDDC6NOMBRJ2N5AFN/