upgrade to 28 beta question?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

upgrade to 28 beta question?

ToddAndMargo
Hi All,

This worked under 27.  Anything different under 28?


Many thanks,
-T


FC 27 -->> FC 28:

# rpm --rebuilddb
# rpm -Va --nofiles --nodigest
   if anything is too new, do a
         # dnf downgrade offender(s)

# dnf --enablerepo=* update --refresh
# dnf install python3-dnf-plugin-system-upgrade
# dnf system-upgrade download --refresh --releasever=28 --allowerasing
# dnf clean packages         <-- optional
# dnf system-upgrade reboot




--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
When we ask for advice, we are usually looking for an accomplice.
    --  Charles Varlet de La Grange
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: upgrade to 28 beta question?

Matthew Miller-2
On Fri, Apr 06, 2018 at 01:22:39PM -0700, ToddAndMargo wrote:
> This worked under 27.  Anything different under 28?

> FC 27 -->> FC 28:
> # rpm --rebuilddb
> # rpm -Va --nofiles --nodigest

These steps shouldn't _generally_ be necessary.


> # dnf --enablerepo=* update --refresh

Depending on what repos you have installed, sure.


> # dnf install python3-dnf-plugin-system-upgrade

(Probably already there?)

> # dnf system-upgrade download --refresh --releasever=28 --allowerasing

If you've done complicated things, you might also want `--best`. On the
other hand, if you _haven't_, you probably don't need `--allowerasing`
either.

> # dnf clean packages         <-- optional
> # dnf system-upgrade reboot

Yep. And you might want to clear /var/cache/dnf after.

--
Matthew Miller
<[hidden email]>
Fedora Project Leader
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]
Reply | Threaded
Open this post in threaded view
|

Re: upgrade to 28 beta question?

ToddAndMargo
On 04/06/2018 01:42 PM, Matthew Miller wrote:
> If you've done complicated things, you might also want `--best`. On the
> other hand, if you_haven't_, you probably don't need `--allowerasing`
> either.


Thank you!

I had to allow raising from some reason when I upgraded
from 26 to 27.  Forgot why.



--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Computers are like air conditioners.
They malfunction when you open windows
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
_______________________________________________
users mailing list -- [hidden email]
To unsubscribe send an email to [hidden email]